aboutsummaryrefslogtreecommitdiffhomepage
path: root/data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-02-08 23:55:33 -0500
committerRalph Amissah <ralph@amissah.com>2014-02-08 23:55:33 -0500
commite43961c041661406ffd0f376cbaab929fe38008f (patch)
treeebae95f42e8c221f4edbaea301ef0dbd67dfe985 /data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst
parentdebian/changelog (5.3.2-1) (diff)
parentdocumentation, minor update (diff)
Merge tag 'sisu_5.3.3' into debian/sid
SiSU 5.3.3
Diffstat (limited to 'data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst')
-rw-r--r--data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst16
1 files changed, 8 insertions, 8 deletions
diff --git a/data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst b/data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst
index a73ae16c..2c43aa92 100644
--- a/data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst
+++ b/data/doc/sisu/markup-samples/manual/en/sisu_sqlite.sst
@@ -55,28 +55,28 @@ may be used interchangeably.
3~ create and destroy database
-!_ --sqlite --createall<br>
+!_ --sqlite --createall \\
initial step, creates required relations (tables, indexes) in existing (sqlite) database (a database should be created manually and given the same name as working directory, as requested) (rb.dbi)
-!_ sisu -d --createdb<br>
+!_ sisu -d --createdb \\
creates database where no database existed before
-!_ sisu -d --create<br>
+!_ sisu -d --create \\
creates database tables where no database tables existed before
-!_ sisu -d --dropall<br>
+!_ sisu -d --dropall \\
destroys database (including all its content)! kills data and drops tables, indexes and database associated with a given directory (and directories of the same name).
-!_ sisu -d --recreate<br>
+!_ sisu -d --recreate \\
destroys existing database and builds a new empty database structure
3~ import and remove documents
-!_ sisu -d --import -v [filename/wildcard]<br>
+!_ sisu -d --import -v [filename/wildcard] \\
populates database with the contents of the file. Imports documents(s) specified to an sqlite database (at an object level).
-!_ sisu -d --update -v [filename/wildcard]<br>
+!_ sisu -d --update -v [filename/wildcard] \\
updates file contents in database
-!_ sisu -d --remove -v [filename/wildcard]<br>
+!_ sisu -d --remove -v [filename/wildcard] \\
removes specified document from sqlite database.