aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/hub.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
committerRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
commit50f12ee84e59d8f74f443c54ab3b11f50ac79346 (patch)
treec36f14b0044525b5e08924c9e25aa8e9f4392472 /lib/sisu/v3/hub.rb
parentdebian/changelog (3.0.13-1) (diff)
parentv2 v3: manpage html (man2html) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v3/hub.rb')
-rw-r--r--lib/sisu/v3/hub.rb4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/sisu/v3/hub.rb b/lib/sisu/v3/hub.rb
index 7b847d4f..5e288b96 100644
--- a/lib/sisu/v3/hub.rb
+++ b/lib/sisu/v3/hub.rb
@@ -157,6 +157,7 @@ module SiSU
when /^xml_scaffold$/; SiSU_XML_scaffold::Source.new(@opt).read # -k xml_scaffold.rb
when /^embedded$/; SiSU_Embedded::Source.new(@opt).read # -m embedded.rb (image and other content) #check
when /^manifest$/; SiSU_Manifest::Source.new(@opt).read # -y manifest.rb
+ when /^qrcode$/; SiSU_QRcode::Source.new(@opt).read # -Q qrcode.rb
when /^sitemaps$/; SiSU_Sitemaps::Source.new(@opt).read # -Y sitemaps.rb
when /^zap$/; SiSU_Zap::Source.new(@opt).read # -Z zap.rb
when /^dbi$/; SiSU_DBI::SiSU_SQL.new(@opt).connect # -D -d dbi.rb
@@ -398,6 +399,9 @@ p "here #{__FILE__} #{__LINE__}" if @opt =~/M/
op('share_src_kdissert','kdissert (kdi)') #% -S share kdissert source
end
end
+ if @opt.act[:qrcode] #% --qrcode, -Q
+ op('qrcode','QRcode')
+ end
if @opt.act[:hash_digests] #% --hash-digests, -N digest tree
op('digests','digests')
end