aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/xhtml.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-29 21:05:12 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-29 21:05:12 -0400
commitaed8d0f1cae7debfb4b9e1858b56d18abbfc7bf5 (patch)
tree0296346dfc87f91371ed086e42231fad226ec455 /lib/sisu/v5/xhtml.rb
parentdebian/changelog (5.6.2-1) (diff)
parentv5 v6: dp, texpdf, copyright_and_license, minor fix, used by texpdf (diff)
Merge tag 'sisu_5.6.3' into debian/sid
SiSU 5.6.3
Diffstat (limited to 'lib/sisu/v5/xhtml.rb')
-rw-r--r--lib/sisu/v5/xhtml.rb4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/sisu/v5/xhtml.rb b/lib/sisu/v5/xhtml.rb
index 14c6bfe9..138ccf6d 100644
--- a/lib/sisu/v5/xhtml.rb
+++ b/lib/sisu/v5/xhtml.rb
@@ -392,7 +392,9 @@ WOK
rdf=SiSU_XML_Tags::RDF.new(@md)
@@xml[:head],@@xml[:body]=[],[]
stylesheet=SiSU_Style::CSS_HeadInfo.new(@md,'xhtml').stylesheet
- encoding=(@sys.locale =~/utf-?8/i) ? '<?xml version="1.0" encoding="UTF-8" standalone="no"?>' : '<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>'
+ encoding=(@sys.locale =~/utf-?8/i) \
+ ? '<?xml version="1.0" encoding="UTF-8" standalone="no"?>'
+ : '<?xml version="1.0" encoding="ISO-8859-1" standalone="no"?>'
@@xml[:open] =<<WOK
#{encoding}
#{stylesheet.css_head_xml}