diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2023-10-30 22:31:28 -0400 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2023-10-30 22:31:28 -0400 |
commit | ad803956c1f7ce1a4b0e820a21881a58a326b7f7 (patch) | |
tree | eb36cfcd0bcbed76a51b0e97e0a46609769ca232 /shell.nix | |
parent | debian/changelog (7.2.1-2) (diff) | |
parent | version & changelog, tag for release (diff) |
Merge tag 'sisu_7.3.0' into debian
SiSU 7.3.0
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 54 |
1 files changed, 27 insertions, 27 deletions
@@ -1,28 +1,28 @@ -#!/usr/bin/env -S nix-shell --pure -{ pkgs ? import <nixpkgs> {} }: +#!/usr/bin/env -S nix-shell --impure +#!nix-shell -i bash +{pkgs ? import <nixpkgs> {}}: with pkgs; -mkShell { - buildInputs = [ - ruby_3_1 - rubyPackages_3_1.rake - rubyPackages_3_1.sqlite3 - rubyPackages_3_1.thor - sqlite - unzip - xz - zip - openssl - #texlive-combined-full - nixFlakes - validatePkgConfig - jq - git - starship - ]; - shellHook = '' - if [[ -e ".envrc" ]]; then - source .envrc - fi - eval "$(starship init bash)" - ''; -} + mkShell { + buildInputs = [ + ruby_3_3 + rubyPackages_3_3.rake + rubyPackages_3_3.sqlite3 + rubyPackages_3_3.thor + sqlite + graphicsmagick + unzip + xz + zip + openssl + #texlive-combined-full + nixFlakes + validatePkgConfig + nix-output-monitor + nix-tree + jq + git + #starship + ]; + shellHook = '' + ''; + } |