summaryrefslogtreecommitdiffhomepage
path: root/devenv.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-02-21 19:08:16 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-04-19 12:46:49 -0400
commitf842299086398f39cfa5fe90eb0aedadea04be0e (patch)
tree4a6c48222e6ecc44896f9b99dc2a6c13cfc2ec75 /devenv.nix
parentnix flake & build, devShells etc. (diff)
nix flake & build, temp. remove gdc
Diffstat (limited to 'devenv.nix')
-rw-r--r--[-rwxr-xr-x]devenv.nix31
1 files changed, 15 insertions, 16 deletions
diff --git a/devenv.nix b/devenv.nix
index 98a02b5..02cca28 100755..100644
--- a/devenv.nix
+++ b/devenv.nix
@@ -1,43 +1,42 @@
-{ pkgs ? import <nixpkgs> { }, name ? "user-env" }: with pkgs;
+{ pkgs ? import <nixpkgs> { }, name ? "user-env" }:
+with pkgs;
buildEnv {
inherit name;
extraOutputsToInstall = [ "out" "man" "lib" ]; # to get all needed symlinks
paths = [
+ # ❯❯❯ nix_related
#nix # if not on NixOS, this is needed
direnv
+ #cachix
nixVersions.unstable #nixFlakes
nix-prefetch-git
validatePkgConfig
- nix-tree jq nix-output-monitor
+ nix-output-monitor
+ nix-tree
+ jq
git
+ gnumake
ps
- ### d_build_related
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
dub
- ## compiler
+ # ❯❯ compiler
dmd
ldc
- #gdc
- #rund
- ## linker
- #lld
- #mold
- ## builder
- #ninja
- #meson
- ### sqlite search related
+ # ❯❯❯ sqlite search related
sqlite
# this will create a script that will rebuild and upgrade your setup; using shell script syntax
(writeScriptBin "nix-rebuild" ''
#!${stdenv.shell}
- cd <path-to-flake> || exit 1
+ #cd <path-to-flake> || exit 1
nix flake update
nix profile upgrade '.*'
'')
# puts in your root the nixpkgs version
- (writeTextFile {
+ (writeTextFile {
name = "nixpkgs-version";
destination = "/nixpkgs-version";
text = lib.version;
- })
+ })
];
}