diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2023-02-21 19:08:16 -0500 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2023-04-19 12:46:49 -0400 |
commit | f842299086398f39cfa5fe90eb0aedadea04be0e (patch) | |
tree | 4a6c48222e6ecc44896f9b99dc2a6c13cfc2ec75 /shell.nix | |
parent | nix flake & build, devShells etc. (diff) |
nix flake & build, temp. remove gdc
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 72 |
1 files changed, 24 insertions, 48 deletions
@@ -4,78 +4,54 @@ with pkgs; mkShell { buildInputs = [ + # ❯❯❯ nix_related + #nix direnv + #cachix nixVersions.unstable #nixFlakes nix-prefetch-git validatePkgConfig - nix-tree jq nix-output-monitor + nix-output-monitor + nix-tree + jq git gnumake ps - ### d_build_related + # ❯❯❯ d_build_related + # ❯❯ package manager dub - ## compiler + # ❯❯ compiler ldc rund - ## linker + # ❯❯ linker #lld #mold - ## builder + # ❯❯ builder #ninja #meson - ### sqlite search related + # ❯❯❯ sqlite search related sqlite - ### tools + # ❯❯❯ tools #aria #wget #curl - ### candy - #starship ]; shellHook = '' - #if [[ -f ".envrc" ]]; then - # source .envrc - #fi nix flake update - echo "" - echo "nix flake metadata:" - nix flake metadata - echo "" - echo "nix flake check:" nix flake check - echo "" - echo "nix flake show:" nix flake show - echo " - nix flake update - nix flake metadata - nix flake check - nix flake show + echo ' + shell.nix echo ❯❯ - nix build or nix develop? (suggestions): + ❯❯ nix flake update && nix flake check --show-trace && nix flake show && nix develop ".#devShell" -c zsh - - nix build - nix build .#default --print-build-logs - nix build --print-build-logs - nix build .#default --print-build-logs |& nom + ❯❯ nix develop + ❯❯ nix develop -c zsh - - nix run - nix run .#default --print-build-logs - nix run default.nix --print-build-logs + ❯❯ nix build + ❯❯ nix build ".#default" --print-build-logs + ❯❯ nix build ".#spine-search-dmd" --print-build-logs |& nom + ❯❯ nix build ".#spine-search-ldc" --print-build-logs |& nom - - nix shell - nix shell --print-build-logs - - - nix develop - nix develop --build .#default --print-build-logs - nix develop --build -f derivation.nix -I .envrc --print-build-logs - nix develop ; eval \$buildPhase - - nix-build |& nom - - nix-instantiate | nix show-derivation | jq - nix-build . --no-out-link | xargs -o nix-tree - nix-tree --derivation .#spine_search - - dub build --compiler=ldmd --build=release --combined --skip-registry=all - " + ❯❯ dub build --compiler=ldmd --build=release --combined --skip-registry=all + ' ''; } |