{
  description = "a sisu like parser & document generator";
  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
  inputs.flake-utils.url = "github:numtide/flake-utils";
  outputs = {
    self,
    nixpkgs,
    flake-utils,
  } @ inputs: let
    pname = "spine";
    version = "0.14.0";
    shell = ./shell.nix; # ./default.nix;
    devEnv = ./nixDevEnv.sh; # ./shell.nix; # ./default.nix; # ./.envrc;
    supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
    forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
    nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
    checkPhase = ''
      runHook preCheck
      dub test --combined --skip-registry=all
      runHook postCheck
    '';
    localOverlay = (final: prev: {
      ldc = prev.callPackage ./nix-overlays/ldc {  };
      dmd = prev.callPackage ./nix-overlays/dmd {  };
      dub = prev.callPackage ./nix-overlays/dub {  };       # -> ?
      #gdc = prev.callPackage ./nix-overlays/gdc {  };      # empty
    });
    pkgsForSystem = system: import nixpkgs {
      overlays = [
        localOverlay
      ];
      inherit system;
    };
    preBuild = ''
      export HOME=$(pwd)
    '';
    installPhase = ''
      runHook preInstall
      mkdir -p $out/bin
      install -m755 ./bin/spine $out/bin/spine
      runHook postInstall
    '';
    postInstall = ''
      echo `ls -la $out/bin/spine`
      $out/bin/spine -v
    '';
  in {
    packages = forAllSystems (system: let
      pkgs-ovl = pkgsForSystem system;
      pkgs = nixpkgsFor.${system};
    in
      with pkgs-ovl; {
        default = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub ldc gnumake]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
          buildPhase = ''
            runHook preBuild
            for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
              echo "- check for D compiler $DC_"
              DC=$(type -P $DC_ || echo "")
              if [ ! "$DC" == "" ]; then break; fi
            done
            if [ "$DC" == "" ]; then exit "Error: could not find D compiler"; fi
            echo "$DC_ used as D compiler to build $pname"
            dub build --cache=local --compiler=$DC --build=$DC_ --combined --skip-registry=all
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-overlay-dmd = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine-dmd";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub dmd gnumake];
          buildPhase = ''
            runHook preBuild
            dub build --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-overlay-ldc = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine-ldc";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub ldc gnumake];
          buildPhase = ''
            runHook preBuild
            dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-nixpkgs-ldc = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine-ldc";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = with pkgs; [sqlite];
          nativeBuildInputs = with pkgs; [dub ldc gnumake];
          buildPhase = ''
            runHook preBuild
            dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        #spine-overlay-gdc = stdenv.mkDerivation {
        #  inherit pname;
        #  inherit version;
        #  meta.mainProgram = "spine-gdc";
        #  executable = true;
        #  src = self;
        #  inherit shell;
        #  inherit devEnv;
        #  buildInputs = [ sqlite ];
        #  nativeBuildInputs = [ dub gdc gnumake ];
        #  buildPhase = ''
        #    runHook preBuild
        #    dub build --cache=local --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
        #    runHook postBuild
        #  '';
        #  inherit preBuild;
        #  inherit checkPhase;
        #  inherit installPhase;
        #  inherit postInstall;
        #};
        #vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
      });
    apps = forAllSystems (system: {
      default = {
        type = "app";
        program = "${self.packages.${system}.default}/bin/spine";
      };
    });
    devShells = forAllSystems (system: let
      pkgs-ovl = pkgsForSystem system;
      pkgs = nixpkgsFor.${system};
      shellHook = ''
        export DFLAGS="-O2 -boundscheck=on"
        export Date=`date "+%Y%m%d"`
      '';
    in
      with pkgs-ovl; {
        dsh-overlay = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          #buildInputs = [ sqlite ];
          #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-overlay-dmd-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          #buildInputs = [ sqlite ];
          #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
          packages = [
            dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-overlay-ldc-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          #buildInputs = [ sqlite ];
          #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
          packages = [
            ldc
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-epub = mkShell {
          name = "spine dev shell for epub output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
            libxml2
            html-tidy
            xmlstarlet
            epubcheck
            ebook_tools
            libxml2
            html-tidy
            xmlstarlet
            epubcheck
            ebook_tools
            epr
            sigil
            calibre #(suite includes: ebook-viewer)
            foliate
          ];
          inherit shellHook;
        };
        dsh-html = mkShell {
          name = "spine dev shell for html output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-latex-pdf = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
            source-sans-pro
            source-serif-pro
            source-code-pro
            texlive.combined.scheme-full
          ];
          inherit shellHook;
        };
        dsh-sqlite = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-i18n = mkShell {
          name = "spine dev shell internationalization, po4a";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
            perl538Packages.Po4a
          ];
          inherit shellHook;
        };
        default = import ./shell.nix {inherit pkgs;};
      });
  };
}