#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
with pkgs;
mkShell {
  buildInputs = [
    # nix_related
    nixFlakes
    nix-prefetch-git
    validatePkgConfig
    jq
    git
    # d_build_related
    rund
    dub
    ldc
    #meson
    # search related
    sqlite
    # candy
    starship
  ];
  shellHook = ''
    if [[ -e ".envrc" ]]; then
      source .envrc
    fi
    eval "$(starship init bash)"
  '';
}