aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-02-09 21:41:51 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-02-09 21:57:51 -0500
commit5334f48a7be29fa85266ca4bdc8cf427eca88ff0 (patch)
treebc4fc2b34be591636bd2d877b85b9870bacabf21 /shell.nix
parentCHANGELOG changes (diff)
nixify, enable nix install sisu for use here
- enable nix install sisu for use on document samples
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100755
index 0000000..ad4bd50
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,24 @@
+#!/usr/bin/env -S nix-shell --pure
+#!nix-shell -i bash
+{ pkgs ? import <nixpkgs> {} }:
+let
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ bundler
+ bundix
+ #ruby
+ #rubyPackages.rake
+ #rubyPackages.sqlite3
+ #rubyPackages.thor
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ unzip
+ xz
+ zip
+ #texlive-combined-full
+ ];
+}