aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-01-17 21:59:05 -0500
committerRalph Amissah <ralph@amissah.com>2014-01-17 21:59:08 -0500
commite87bf6da34afbfd286d84df18a4d680c5df5ea53 (patch)
tree3259ff8f612907a9e636846b05106aa3d6c67eb0 /debian
parentdebian/control depend on ruby | ruby-interpreter; remove rubygems dependency (diff)
debian/sisu.install use vendor_ruby; use bin/sisu (remove debian/bin/sisu)
Diffstat (limited to 'debian')
-rw-r--r--debian/bin/sisu232
-rw-r--r--debian/sisu.install4
2 files changed, 2 insertions, 234 deletions
diff --git a/debian/bin/sisu b/debian/bin/sisu
deleted file mode 100644
index 8df1ae88..00000000
--- a/debian/bin/sisu
+++ /dev/null
@@ -1,232 +0,0 @@
-#! /usr/bin/ruby1.9.1
-# encoding: utf-8
-#SiSU: copyright (C) 1997 - 2014 Ralph Amissah; License GPL 3, see appended program information
-begin
- def ruby_version_ok?(base_version)
- @v ||=RUBY_VERSION.scan(/\d+/)
- vb=base_version.scan(/\d+/)
- if @v[0].to_i < vb[0].to_i \
- or @v[0].to_i == vb[0].to_i \
- && @v[1].to_i < vb[1].to_i \
- or @v[0].to_i == vb[0].to_i \
- && @v[1].to_i == vb[1].to_i \
- && @v[1].to_i < vb[2].to_i
- raise "Please, use Ruby#{vb} or later, current Ruby #{RUBY_VERSION}"
- else check_incompatible_ruby_build?
- end
- end
- def check_incompatible_ruby_build?
- require 'rbconfig'
- e=Config::CONFIG
- if RUBY_VERSION == '1.9.2' \
- && e['PATCHLEVEL'].to_i < 180
- raise <<WOK
-There are known issues with early versions of ruby1.9.2.
-Please, use Ruby 1.9.2p180 or later,
-current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
-#{%x{ruby -v}.strip.to_s}
-
-WOK
- end
- end
- def check_sisu_legacy_ruby_version?
- rbv_sisu_legacy='1.9.2' #'1.8.7'
- ruby_version_ok?(rbv_sisu_legacy)
- end
- def check_sisu_stable_ruby_version?
- rbv_sisu_stable='1.9.2'
- ruby_version_ok?(rbv_sisu_stable)
- end
- def check_sisu_dev_ruby_version?
- rbv_sisu_dev='1.9.2'
- ruby_version_ok?(rbv_sisu_dev)
- end
- def require_hub_path(sisu_path_specified_lib_)
- if sisu_path_specified_lib_ \
- && FileTest.file?("#{sisu_path_specified_lib_}/#{SiSU_lib}/hub.rb")
- "#{sisu_path_specified_lib_}/#{SiSU_lib}"
- else
- SiSU_lib
- end
- end
-#% sisu branch
- $VERBOSE=nil
- $KCODE='u' if RUBY_VERSION < '1.9'
- argv=$*
- SiSU_called_from_directory=Dir.pwd
- require 'rubygems'
- check_sisu_stable_ruby_version?
- default_version=if __FILE__ =~/gem/ \
- and __FILE__ =~/\/sisu-[45]\.(?:\d+|[a-z])\.(?:\d+|[a-z])\//
- SiSU_version_dir=case __FILE__
- when /\/sisu-5\.(?:\d+|[a-z])\.(?:\d+|[a-z])\// then 'v5'
- when /\/sisu-4\.(?:\d+|[a-z])\.(?:\d+|[a-z])\// then 'v4'
- else 'v4'
- end
- else 'v4'
- end
- SiSU_version_dir=case $0
- when /\bsisu4$/ then 'v4'
- when /\bsisu5$/ then 'v5'
- else
- case argv.inspect
- when /"(?:--v4|--current|--stable)"/ then 'v4'
- when /"(?:--v5|--next|--dev)"/ then 'v5'
- else default_version
- end
- end
-#% $0 File.expand_path($0)
- e=Config::CONFIG
- SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[45]?$/
- nil
- elsif $0 !~ /^#{e['bindir']}\/sisu[45]?$/ \
- && File.expand_path($0) =~/bin\/sisu[45]?$/ \
- && FileTest.file?($0)
- File.expand_path($0).sub(/\/bin\/sisu[45]?$/,'')
- else
- nil
- end
- SiSU_lib="sisu/#{SiSU_version_dir}"
- sisu_path_specified_lib_=SiSU_path_base \
- ? File.expand_path($0).sub(/bin\/sisu[45]?$/,'lib')
- : nil
- SiSU_path_specified_Version_=if __FILE__ =~/gem/
- spec = Gem::Specification.find_by_name("sisu")
- spec.gem_dir + "/data/sisu/#{SiSU_version_dir}/v/version.yml"
- elsif SiSU_path_base
- "#{SiSU_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"
- else nil
- end
- SiSU_path_lib="#{require_hub_path(sisu_path_specified_lib_)}"
-#% $*
- require "#{SiSU_path_lib}/hub"
- lng_lst = %w[am bg bn br ca cs cy da de el en eo es et eu fi fr ga gl he hi hr hy ia is it ja ko la lo lt lv ml mr nl nn no oc pl pt pt_BR ro ru sa se sk sl sq sr sv ta te th tk tr uk ur us vi zh]
- lng_lst_rgx=lng_lst.join('|')
- argv_sub_files={}
- argv_sub_mods=[]
- argv.each do |x|
- if x =~/^-+/
- argv_sub_mods << x
- elsif x =~/\.ss[tm]/
- if x =~/\//
- markup_path,markup_file =(/(\S+\/)((?:#{lng_lst_rgx})?[^\/]+)/).match(x)[1,2]
- if not argv_sub_files[markup_path]
- argv_sub_files[markup_path]=[]
- end
- argv_sub_files[markup_path] << markup_file
- else
- if not argv_sub_files['./']
- argv_sub_files['./']=[]
- end
- argv_sub_files['./'] << x
- end
- end
- end
- if argv_sub_files.length > 0
- argv_sub_files.each_pair do |markup_dir,markup_file|
- $sisu_document_markup_directory=markup_dir.gsub(/\/$/,'')
- argv_sub=argv_sub_mods + markup_file
- if FileTest.directory?(markup_dir)
- system("cd #{markup_dir}")
- Dir.chdir(markup_dir)
- $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/\/(?:#{lng_lst_rgx})$/,'')
- SiSU::HubMaster.new(argv_sub)
- Dir.chdir(SiSU_called_from_directory)
- system("cd #{SiSU_called_from_directory}")
- elsif markup_dir =~/https?:/
- markup_file.each do |mf|
- (FileTest.file?(mf)) \
- ? (puts 'requested remote file already exists in current directory ' + Dir.pwd + ' using ' + mf)
- : (system("wget #{markup_dir}/#{mf}"))
- end
- $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/\/(?:#{lng_lst_rgx})$/,'')
- argv_sub=argv_sub_mods + markup_file
- SiSU::HubMaster.new(argv_sub)
- else p "Error directory specified #{markup_dir} not found"
- end
- end
- else
- $sisu_document_markup_directory=Dir.pwd.gsub(/\/$/,'')
- $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/(^|\/)(?:#{lng_lst_rgx})$/,'')
- SiSU::HubMaster.new(argv)
- end
-rescue
- STDERR.puts 'ERROR'
- STDERR.puts $!
- STDERR.puts $@
- require 'rbconfig'
- require 'rubygems'
- e=Config::CONFIG
- puts %{
- #{%x{ruby -v}.strip.to_s}
- #{RUBY_VERSION}
- ruby version: #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
- ruby named: #{e['ruby_version']}
- rubylib: #{e['rubylibdir']}
- rubylib local: #{e['sitelibdir']}
- gem dir: #{Gem.dir}
- gem path: #{Gem.path}
- }
- system(%{echo "
- system RUBYPATH: ${RUBYPATH}
- system RUBYLIB: ${RUBYLIB}
- "})
-end
-__END__
-
- * Name: SiSU
-
- * Description: a framework for document structuring, publishing and search
-
- * Author: Ralph Amissah
-
- * Copyright: (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
- 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014 Ralph Amissah,
- All Rights Reserved.
-
- * License: GPL 3 or later:
-
- SiSU, a framework for document structuring, publishing and search
-
- Copyright (C) Ralph Amissah
-
- This program is free software: you can redistribute it and/or modify it
- under the terms of the GNU General Public License as published by the Free
- Software Foundation, either version 3 of the License, or (at your option)
- any later version.
-
- This program is distributed in the hope that it will be useful, but WITHOUT
- ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
- more details.
-
- You should have received a copy of the GNU General Public License along with
- this program. If not, see <http://www.gnu.org/licenses/>.
-
- If you have Internet connection, the latest version of the GPL should be
- available at these locations:
- <http://www.fsf.org/licensing/licenses/gpl.html>
- <http://www.gnu.org/licenses/gpl.html>
-
- <http://www.sisudoc.org/sisu/en/manifest/gpl.fsf.html>
-
- * SiSU uses:
- * Standard SiSU markup syntax,
- * Standard SiSU meta-markup syntax, and the
- * Standard SiSU object citation numbering and system
-
- * Hompages:
- <http://www.jus.uio.no/sisu>
- <http://www.sisudoc.org>
-
- * Download:
- <http://www.sisudoc.org/sisu/en/SiSU/download.html>
-
- * Git
- <http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=summary>
- <http://sources.sisudoc.org/?p=code/sisu.git;a=blob;f=bin/sisu;hb=HEAD>
- <http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=blob_plain;f=debian/bin/sisu;hb=refs/heads/debian/sid>
-
- * Ralph Amissah
- <ralph@amissah.com>
- <ralph.amissah@gmail.com>
diff --git a/debian/sisu.install b/debian/sisu.install
index f6564395..720d2bbf 100644
--- a/debian/sisu.install
+++ b/debian/sisu.install
@@ -1,4 +1,4 @@
-debian/bin/sisu usr/bin
+bin/sisu usr/bin
bin/sisu4 usr/bin
bin/sisu5 usr/bin
bin/sisu-concordance usr/bin
@@ -8,7 +8,7 @@ bin/sisu-html* usr/bin
bin/sisu-odf usr/bin
bin/sisu-txt usr/bin
bin/sisu-webrick usr/bin
-lib/sisu usr/lib/ruby/1.9.1
+lib/sisu usr/lib/ruby/vendor_ruby
conf/sisu etc
data/sisu usr/share
data/doc/sisu usr/share/doc