aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 0e74e8c..f2908a3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -45,9 +45,9 @@
devShells = forAllSystems (system: let
pkgs = nixpkgsFor.${system};
shellHook = ''
- export DFLAGS="-O2 -boundscheck=on"
export Date=`date "+%Y%m%d"`
## set local values in .envrc-local (or here if you must)
+ echo " ❯❯ ./result/bin/spine -v --source --pod --epub --html --html-link-pdf --html-link-curate --html-link-markup --curate --output=./OUTPUT_TEST_sisudocSpine ./markup/pod/*";
'';
in
with pkgs; {
@@ -107,6 +107,13 @@
dub
gnumake
sqlite
+ # ❯❯ text-mode web browsers
+ elinks
+ links2
+ lynx
+ w3m
+ # ❯❯ light graphical
+ #dillo
];
inherit shellHook;
};