summaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-12-03 18:05:52 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2024-12-03 18:18:07 -0500
commit5e8679d47be998a1e9ca8928ca96121fc44701e3 (patch)
treef9132714c0c90381c333f25fcf4a2b60c6d8bb5f /flake.nix
parentnix build houskeeping, version updates, incl. dmd & dub (diff)
nix build flake.nix fix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 1df2424..c2c18d9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,7 +2,7 @@
description = "a sisu like document parser search form";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
- inputs.d-overlay = {
+ inputs.spine-d-overlay = {
url = "git://git.sisudoc.org/package/dlang-nix-overlays-and-flake";
inputs.nixpkgs.follows = "nixpkgs";
flake = true;
@@ -11,7 +11,7 @@
self,
nixpkgs,
flake-utils,
- d-overlay,
+ spine-d-overlay,
...
}@inputs: let
pname = "spine_search";
@@ -93,8 +93,8 @@
src = self;
inherit shell;
inherit devEnv;
- buildInputs = [sqlite];
- nativeBuildInputs = [dub dmd gnumake];
+ buildInputs = with pkgs-nix; [sqlite];
+ nativeBuildInputs = with pkgs-nix; [dub dmd gnumake];
buildPhase = ''
runHook preBuild
buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
@@ -116,8 +116,8 @@
src = self;
inherit shell;
inherit devEnv;
- buildInputs = [sqlite];
- nativeBuildInputs = [dub ldc gnumake];
+ buildInputs = with pkgs-nix; [sqlite];
+ nativeBuildInputs = with pkgs-nix; [dub ldc gnumake];
buildPhase = ''
runHook preBuild
buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
@@ -208,7 +208,7 @@
'';
in
with pkgs-nix; {
- dsh-d-overlay = d-overlay.devShells.${system}.default;
+ dsh-d-overlay = spine-d-overlay.devShells.${system}.default;
dsh-overlay = mkShell {
name = "spine base dev shell";
inherit shell;