aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-05-07 10:36:50 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2024-05-07 10:37:02 -0400
commit05111f648ef3afc8f53b2326318f20f1e85fb31f (patch)
treed7ff1ae5a8ec61deedd128af227adf84ec09ba74 /flake.nix
parent.envrc-nix info (diff)
dub (dlang) prefer dub run to dub build
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 495e86c..93752a5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -69,7 +69,7 @@
done
if [ "$DC" == "" ]; then exit "Error: could not find D compiler"; fi
echo "$DC_ used as D compiler to build $pname"
- buildCMD="dub build --cache=local --compiler=$DC --build=$DC_ --combined --skip-registry=all"
+ buildCMD="dub run --cache=local --compiler=$DC --build=$DC_ --combined --skip-registry=all"
echo $buildCMD
$buildCMD
echo $buildCMD
@@ -92,7 +92,7 @@
nativeBuildInputs = with pkgs-ovl; [dub dmd gnumake];
buildPhase = ''
runHook preBuild
- buildCMD="dub build --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
+ buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
echo $buildCMD
$buildCMD
echo $buildCMD
@@ -115,7 +115,7 @@
nativeBuildInputs = with pkgs-ovl; [dub ldc gnumake];
buildPhase = ''
runHook preBuild
- buildCMD="dub build --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
+ buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
echo $buildCMD
$buildCMD
echo $buildCMD
@@ -138,7 +138,7 @@
nativeBuildInputs = with pkgs-ovl; [dub dmd gnumake];
buildPhase = ''
runHook preBuild
- buildCMD="dub build --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
+ buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
echo $buildCMD
$buildCMD
echo $buildCMD
@@ -161,7 +161,7 @@
nativeBuildInputs = with pkgs-ovl; [dub ldc gnumake];
buildPhase = ''
runHook preBuild
- buildCMD="dub build --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
+ buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
echo $buildCMD
$buildCMD
echo $buildCMD
@@ -184,7 +184,7 @@
# nativeBuildInputs = with pkgs-ovl; [ dub gdc gnumake ];
# buildPhase = ''
# runHook preBuild
- # dub build --cache=local --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
+ # dub run --cache=local --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
# runHook postBuild
# '';
# inherit preBuild;