aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-07-11 21:44:48 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2023-07-11 23:45:24 -0400
commit9410a4edcdad64197e3fed36926da1846d3ede88 (patch)
tree265d41375791219e2e26a2af979de57080cd51d3 /flake.nix
parentocda, improve doc markup structure error messages (diff)
flake.nix minor
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/flake.nix b/flake.nix
index f784f98..af79655 100644
--- a/flake.nix
+++ b/flake.nix
@@ -31,6 +31,9 @@
];
inherit system;
};
+ preBuild = ''
+ export HOME=$(pwd)
+ '';
installPhase = ''
runHook preInstall
mkdir -p $out/bin
@@ -57,9 +60,6 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub ldc gnumake]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
- preBuild = ''
- export HOME=$(pwd)
- '';
buildPhase = ''
runHook preBuild
for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
@@ -72,6 +72,7 @@
dub build --cache=local --compiler=$DC --build=$DC_ --combined --skip-registry=all
runHook postBuild
'';
+ inherit preBuild;
inherit checkPhase;
inherit installPhase;
inherit postInstall;
@@ -86,14 +87,12 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub dmd gnumake];
- preBuild = ''
- export HOME=$(pwd)
- '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all
runHook postBuild
'';
+ inherit preBuild;
inherit checkPhase;
inherit installPhase;
inherit postInstall;
@@ -108,14 +107,12 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub ldc gnumake];
- preBuild = ''
- export HOME=$(pwd)
- '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all
runHook postBuild
'';
+ inherit preBuild;
inherit checkPhase;
inherit installPhase;
inherit postInstall;
@@ -130,14 +127,12 @@
inherit devEnv;
buildInputs = with pkgs; [sqlite];
nativeBuildInputs = with pkgs; [dub ldc gnumake];
- preBuild = ''
- export HOME=$(pwd)
- '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all
runHook postBuild
'';
+ inherit preBuild;
inherit checkPhase;
inherit installPhase;
inherit postInstall;
@@ -157,6 +152,7 @@
# dub build --cache=local --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
# runHook postBuild
# '';
+ # inherit preBuild;
# inherit checkPhase;
# inherit installPhase;
# inherit postInstall;