aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-05-15 18:10:04 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-05-15 22:25:58 -0400
commit924fabf26347cf2da0a770cd16f956c26e4064f9 (patch)
tree80c97145dca8188df5f7131694e5dc2f5990b7ff /shell.nix
parentcgi.d arsd update (diff)
nix-build cleanup, external sources localized
- clean up as external sources kept locally, in ./src/ext_depends/ - remove dub2nix dependency, no longer needed/used
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 445e0b1..a426e51 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,19 @@
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
- (import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
+ (
+ with pkgs; [
+ nixFlakes
+ rund
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ ]
+ )
];
shellHook = ''
if [[ -e ".envrc" ]]; then