aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-10-23 19:49:43 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-11-27 19:51:25 -0500
commitc4f6c86999ec8fe3b610ac269a121c9fa424daf5 (patch)
tree9251611c030c29af99bfa59bda94521c3500ad94 /shell.nix
parentnix .envrc related (diff)
dlang dub & nix build related, includes dep update
- nix-shell --pure - nix-build - dub build --compiler=ldc2 --build=release --force
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index 48b87d1..0ac55ea 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,8 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = with pkgs; [
+with pkgs;
+mkShell {
+ buildInputs = [
# nix_related
nixFlakes
nix-prefetch-git
@@ -13,11 +14,8 @@ pkgs.mkShell {
dub
ldc
#meson
- # candy
- starship
- # # search_sqlite_related
- # # search related
- # sqlite
+ # search related
+ sqlite
# # pdf_latex_related
# source-sans-pro
# source-serif-pro
@@ -33,6 +31,8 @@ pkgs.mkShell {
# sigil
# calibre # (ebook-viewer)
# foliate
+ # candy
+ starship
];
shellHook = ''
if [[ -e ".envrc" ]]; then