aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..5b97ffe
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+mkShell {
+ buildInputs = with pkgs; [
+ ninja dub
+ meson git
+ ldc #ldc dmd gdc
+ sqlite
+ validatePkgConfig
+ #gnumake gcc gdc cmake
+ #dzen2
+ ];
+ shellHook = ''
+ echo `ldc2 --version`
+ '';
+ COMPILER = "ldc2";
+}