aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-06-27 16:59:44 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-08-01 07:46:58 -0400
commit4d5ee2ead874c7a436faa8754eb99215927ea94d (patch)
treec1519c0b8db2302bcf46ffdce04a6580d7a012e5 /shell.nix
parentorg-mode code block headers (diff)
dir rename ./sundry (from ./misc)
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix29
1 files changed, 14 insertions, 15 deletions
diff --git a/shell.nix b/shell.nix
index a426e51..7f37eee 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,20 +1,19 @@
+#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
- buildInputs = with pkgs; [
- (
- with pkgs; [
- nixFlakes
- rund
- dub
- ldc
- sqlite
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- ]
- )
- ];
+ buildInputs = with pkgs; [(
+ with pkgs; [
+ nixFlakes
+ rund
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ ]
+ )];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc