aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix29
1 files changed, 14 insertions, 15 deletions
diff --git a/shell.nix b/shell.nix
index a426e51..7f37eee 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,20 +1,19 @@
+#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
- buildInputs = with pkgs; [
- (
- with pkgs; [
- nixFlakes
- rund
- dub
- ldc
- sqlite
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- ]
- )
- ];
+ buildInputs = with pkgs; [(
+ with pkgs; [
+ nixFlakes
+ rund
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ ]
+ )];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc